Issue with identifying Docker Processes within the Agent
Incident Report for Instana
Resolved
This incident has been resolved.
Posted Jan 30, 2024 - 11:52 UTC
Monitoring
A new version of the agent which fixes this issue is available on the download site.
Posted Jan 29, 2024 - 16:19 UTC
Identified
Issue with identifying Docker Processes within the Agent. The Agent will identify these as Containerd and this can lead to missing or wrong linked Processes within the Backend that are therefore also not showing up as Kubernetes services.

A workaround fix for that is to pin to
https://github.com/instana/agent-updates/commit/c23032e284acad64344dd0ef3bda130d5429e18c

Engineering is working on permanent fix.
Posted Jan 26, 2024 - 20:38 UTC
Investigating
Issue with identifying Docker Processes within the Agent. The Agent will identify these as Containerd and this can lead to missing or wrong linked Processes within the Backend that are therefore also not showing up as Kubernetes services.

A workaround fix for that is to pin to
https://github.com/instana/agent-updates/commit/c23032e284acad64344dd0ef3bda130d5429e18c

Engineering is working on permanent fix.
Posted Jan 26, 2024 - 20:36 UTC
This incident affected: Agents and Sensors.